Testing (SimpleTest) Install/Run Error | Drupal 8

Testing (SimpleTest) Install/Run Error

Submitted by editor on Thu, 07/09/2020 - 13:21
Question

Error N°1 : PHPunit not found

Error N°2 : BrowserTestBase::setUp() must be compatible with PHPUnit

Error N°1 : PHPunit not found

If uou have a message like : Add Phpunit via composer

CAUTION : PHPunit Version >= 8 is not compatable with drupal, so use the 7

composer require --dev phpunit/phpunit:7

Note : Probably you will have errors like:
PHPunit Test failed to complete; Error: Class "Symfony\Bridge\PhpUnit\SymfonyTestsListener" does not exis
Error: Class 'Behat\Mink\Driver\GoutteDriver' not found

in this case, add the following libraries
composer require --dev symfony/phpunit-bridge
composer require --dev behat/mink-goutte-driver

Error N°2 : BrowserTestBase::setUp() must be compatible with PHPUnit

Probable your phpunit version is >7 (8 or 9).
1. Chenge the version in composer.json file
"phpunit/phpunit": "^7.0"

2. Run composer update

.

Add new comment

Plain text

  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Web page addresses and email addresses turn into links automatically.