Composer - Problems and Errors | Drupal 8

Composer - Problems and Errors

Submitted by editor on Sun, 10/01/2017 - 21:36

 

Conflict with your requirements or minimum-stability

If you have a message like this, probably you have a deadlock cause of the dependencies.
The requested package symfony/psr-http-message-bridge v0.2 is satisfiable by symfony/psr-http-message-bridge[v0.2] but these conflict with your requirements or minimum-stability.

You can try a full cleanup but must be very careful.
Note : Make a good backup of your current files.

#Remove drupal code and contrib modules.
rm -rf vendor && rm -rf core && rm -rf modules/contrib && rm -f composer.lock
#update drupal , modules and dependencies.

composer require drupal/core:8.3.7 --update-with-dependencies
#Or set the version as:

composer require drupal/core:^8.4 --update-with-dependencies

 

 

Add new comment